Cloudi-Fi - No DHCP pool available for requested subnet – Incident details

All systems operational

No DHCP pool available for requested subnet

Resolved
Degraded performance
Started 6 months agoLasted about 1 hour

Affected

DHCP

Degraded performance from 10:41 AM to 10:57 AM, Operational from 10:57 AM to 12:01 PM

Updates
  • Update
    Update

    The root cause was the mis-handling of devices at the dhcp level leading to them not being associated with a pool. Only guest devices were affected. This mis-handling was introduced with the latest release (see https://status.cloudi-fi.net/cm9cj09s00001exvbas2uckxn)

  • Resolved
    Resolved

    Since the workaround has been applied, everything appears to be functioning as expected.

    Devices are now able to obtain IP addresses from the appropriate DHCP pools without issue.

    However, please note that a permanent fix is still to be implemented. Our engineering team continues to work on a long-term solution to fully address the root cause.

  • Monitoring
    Monitoring
    We implemented a fix and are currently monitoring the result.
  • Investigating
    Investigating

    Incident Summary

    We have identified an issue where, in certain cases, no DHCP pool is available for the requested subnet.
    This results in failure to assign IP addresses for devices or services relying on dynamic address allocation within those subnets.

    Our technical team is currently investigating the root cause and working toward a resolution.


    Impact

    • Devices attempting to connect to affected subnets may fail to obtain an IP address.